Cómo instalar el controlador nvidia en Debian Stretch

En resumen: terminal
1. # apt instalar nvidia-detect
$ nvidia-detect
2. Agregue los componentes “contrib” y “non-free” a /etc/apt/sources.list, por ejemplo:
# Debian 9 “Stretch”
deb http://httpredir.debian.org/debian/ stretch principal contrib no gratis
3. # apt update && apt upgrade [Use “apt” en lugar de “apt-get”. Es la versión más nueva y tiende a gestionar mejor los conflictos.
# apt install linux-headers – $ (uname -r | sed ‘s / [^ -] * – [^ -] * – //’) controlador nvidia-legacy-304xx
4. # instalar llvm-3.9 clang-3.9
5. # reiniciar

Introducción
Hay muchos consejos sobre cómo instalar el controlador nvidia en las distribuciones de Linux. Utilizo Debian y AcademiX_debian, por lo que es normal que primero vaya a los sitios de Debian. Pero cuando la necesidad lo empuja así: “https://linuxconfig.org/how-to-install-the-latest-nvidia-drivers-on-debian-9-stretch-linux”. Eso es porque, con toda la ciencia que tenemos a nuestra disposición, la teoría es una cosa y es otra práctica.

Nouveau o Nvidia?
Para el usuario simple, sin actividades especiales, Nouveau está haciendo su trabajo. Si manipula películas, necesita aplicaciones como Blender, KDEnlive, Wings3D u otras, donde no necesita “levantar su barba” al lado de ellas. Perdona la expresión, no tengo habilidades en el campo.
Para mí, que tiene dos tarjetas gráficas Nvidia y estaba usando un controlador newvau, el problema apareció en el proyecto AcademiX [https://academixproject.com/] también de una pregunta. Y como todavía tenía nvidia y un auto de prueba, dije que iba a buscar. Lo primero es saber qué tablero Nvidia tenemos y qué controlador necesitamos.

NOTA: Las salidas de los terminales son ejemplos personales.

Instalación
1. Lo primero es saber qué tablero Nvidia tenemos y qué controlador necesitamos.

Abrimos “terminal” y “root”

# apt install nvidia-detect

salida pishta @ debian: ~ $ su
Contraseña: [ingrese la contraseña de root que no será visible
root @ debian: / home / pishta # apt install nvidia-detect [instala el “nvidia-detect”

Ejecutando “nvidia-detect”
salida pishta @ debian: ~ $ nvidia-detect
GPU NVIDIA detectadas:
02: 00.0 Controlador compatible con VGA [0300]: NVIDIA Corporation G71 [GeForce 7900 GS] [10de: 0292] (rev a1)

Tarjeta de cheques: NVIDIA Corporation G71 [GeForce 7900 GS] (rev a1)
Su tarjeta solo es compatible con la serie de controladores heredados 304.
Se recomienda instalar el
nvidia-legacy-304xx-controlador
paquete.

2. Agregue los componentes “contrib” y “non-free” a /etc/apt/sources.list, por ejemplo:

# Debian 9 “Stretch”
deb http://httpredir.debian.org/debian/ stretch principal contrib no gratis

3. Solo ahora que tenemos la recomendación del controlador correcto, lo vamos a instalar

4. Actualizar la lista de paquetes disponibles. Instale los paquetes apropiados para los encabezados de linux y los módulos del kernel:
# apt update [si es necesario, requiere y actualiza
# apt install linux-headers – $ (uname -r | sed ‘s / [^ -] * – [^ -] * – //’) controlador nvidia-legacy-304xx

driver nvidia-legacy-304xx, este es mi caso; Cada uno deberá tener en cuenta la recomendación recibida y completarla mirando aquí:
https://wiki.debian.org/NvidiaGraphicsDrivers

Esto instalará el paquete “nvidia-legacy-304xx driver”. DKMS construirá el módulo nvidia para su sistema a través del paquete “nvidia-legacy-304xx-kernel-dkms”.

PRECAUCIÓN! REEMPLAZAR EL PASO SIGUIENTE [5. Crear un archivo de configuración del servidor Xorg ___ no me engañó: no pude pasar el “inicio de sesión”] con

5. LLVM
La siguiente parte (no es estrictamente necesaria, ¡fui yo!) Pero LLVM es utilizado por algunos paquetes de gráficos y es mejor asegurarse de que ya tiene instalada la última versión disponible, especialmente porque hay versiones anteriores Disponible en archivos.

Más información encontrada en Synnaptic:
“Clang” es el compilador de front-end “llvm” diseñado para reemplazar la colección de compilación de GNU (GCC)
La máquina virtual de bajo nivel “llvm” (LLVM) es una colección de bibliotecas y herramientas que facilitan la creación de compiladores, optimizadores, generadores de código justo a tiempo y muchos otros compiladores.

En este momento, 3.9 es la última versión y hay un candidato de lanzamiento 4.0 disponible. 3.9 debe ser la versión mínima para instalar.

# apt install llvm-3.9 clang-3.9

6. reiniciar
Eso es todo. Ahora, reinicie la computadora para activar la lista negra y pruebe su tarjeta para asegurarse de que todo funcione.

En “Menú principal” a “Sistema”> “Administración”> encontraremos “Configuración del servidor Nvidia X”

fuentes
– https://wiki.debian.org/NvidiaGraphicsDrivers
– llvm, clang: https://linuxconfig.org/how-to-install-the-latest-nvidia-drivers-on-debian-9-stretch-linux gracias a Luta Dumitru (por este consejo)
– Synaptic

Leave a Comment